import re
regex = re.compile(r"([^>]){{(.*?)}}", flags=re.MULTILINE)
test_str = "The quick brown {{ fox }} jumped over the lazy <em>{{ dog }}</em>"
subst = "$1<em>$2</em>"
result = regex.sub(subst, test_str)
if result:
print(result)