// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)([^>]){{(.*?)}}").unwrap();
let string = "The quick brown {{ fox }} jumped over the lazy <em>{{ dog }}</em>";
let substitution = "$1<em>$2</em>";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}