#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?=^.{10}$)^([a-z]+\d[a-z0-9]*|\d+[a-z][a-z0-9]*)$"
Local $sString = "good:" & @CRLF & _
"abc124532a" & @CRLF & _
"1234565a33" & @CRLF & _
"a123432322" & @CRLF & _
"23423aasbd" & @CRLF & _
"" & @CRLF & _
"bad:" & @CRLF & _
"12312basd" & @CRLF & _
"basd1232131" & @CRLF & _
"1231243251" & @CRLF & _
"absidjbais" & @CRLF & _
"asdgv" & @CRLF & _
"2673" & @CRLF & _
".=778)" & @CRLF & _
"asd67876$d"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")