const regex = /(?=^.{10}$)^([a-z]+\d[a-z0-9]*|\d+[a-z][a-z0-9]*)$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?=^.{10}$)^([a-z]+\\d[a-z0-9]*|\\d+[a-z][a-z0-9]*)$', 'gm')
const str = `good:
abc124532a
1234565a33
a123432322
23423aasbd
bad:
12312basd
basd1232131
1231243251
absidjbais
asdgv
2673
.=778)
asd67876\$d`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}