$re = '/(?=^.{10}$)^([a-z]+\d[a-z0-9]*|\d+[a-z][a-z0-9]*)$/m';
$str = 'good:
abc124532a
1234565a33
a123432322
23423aasbd
bad:
12312basd
basd1232131
1231243251
absidjbais
asdgv
2673
.=778)
asd67876$d';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);