using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?=^.{10}$)^([a-z]+\d[a-z0-9]*|\d+[a-z][a-z0-9]*)$";
string input = @"good:
abc124532a
1234565a33
a123432322
23423aasbd
bad:
12312basd
basd1232131
1231243251
absidjbais
asdgv
2673
.=778)
asd67876$d";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}