import re
regex = re.compile(r"""
(?(DEFINE)
(?<varchar> [[:alnum:]] | [-_] )
(?<funcname> [[:alpha:]](?&varchar)* )
(?<varname> \$(?&funcname) )
(?<typepart> [[:alpha:][[:alnum:]]*)
(?<typename> \[ (?&typepart) ( \.(?&typepart) )* \] )
(?<arg> (?&typename)? \s* (?&varname) )
(?<arglist> (?&arg) ( \s*,\s* (?&arg) )* )
(?<args> ( \( (?&arglist)? \) )? )
(?<func_decl> ^ \s* function \s+ (?&funcname) \s* (?&args) \s* \{ )
)
(?&func_decl)
""", flags=re.VERBOSE | re.MULTILINE)
test_str = ("function Main ($x, [string]$y) {\n"
" function Get-Content {\n"
" function main_- () { \n"
"function main([string.Array] $mfd_) { ")
subst = ""
result = regex.sub(subst, test_str)
if result:
print(result)