import Foundation
let pattern = #"""
(?(DEFINE)
(?<varchar> [[:alnum:]] | [-_] )
(?<funcname> [[:alpha:]](?&varchar)* )
(?<varname> \$(?&funcname) )
(?<typepart> [[:alpha:][[:alnum:]]*)
(?<typename> \[ (?&typepart) ( \.(?&typepart) )* \] )
(?<arg> (?&typename)? \s* (?&varname) )
(?<arglist> (?&arg) ( \s*,\s* (?&arg) )* )
(?<args> ( \( (?&arglist)? \) )? )
(?<func_decl> ^ \s* function \s+ (?&funcname) \s* (?&args) \s* \{ )
)
(?&func_decl)
"""#
let regex = try! NSRegularExpression(pattern: pattern, options: [.anchorsMatchLines, .allowCommentsAndWhitespace])
let testString = #"""
function Main ($x, [string]$y) {
function Get-Content {
function main_- () {
function main([string.Array] $mfd_) {
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)