#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)\A([^\x0A\x0D]+)(?:\x0D\x0A|[\x0A\x0D])"
Local $sString = "ABCDEFGHIJKLMNOPQRSTUVWXYZ" & @CRLF & _
"abcdefghijklmnopqrstuvwxyz" & @CRLF & _
"0123456789" & @CRLF & _
"This is a pen." & @CRLF & _
""
Local $sSubst = ""$1"|"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)