re = /\A([^\x0A\x0D]+)(?:\x0D\x0A|[\x0A\x0D])/m
str = 'ABCDEFGHIJKLMNOPQRSTUVWXYZ
abcdefghijklmnopqrstuvwxyz
0123456789
This is a pen.
'
subst = '"$1"|'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result