use strict;
my $str = 'ABCDEFGHIJKLMNOPQRSTUVWXYZ
abcdefghijklmnopqrstuvwxyz
0123456789
This is a pen.
';
my $regex = qr/\A([^\x0A\x0D]+)(?:\x0D\x0A|[\x0A\x0D])/mp;
my $subst = '"$1"|';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";