$re = '/\A([^\x0A\x0D]+)(?:\x0D\x0A|[\x0A\x0D])/m';
$str = 'ABCDEFGHIJKLMNOPQRSTUVWXYZ
abcdefghijklmnopqrstuvwxyz
0123456789
This is a pen.
';
$subst = "\"$1\"|";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;