import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\"\"\"(?:[^\"\\\\]|\\\\.|\\\\\\n)*\"\"\"|\\'\\'\\'(?:[^'\\\\]|\\\\.|\\\\\\n)*\\'\\'\\'|\"(?:[^\"\\\\\\n]|\\\\.|\\\\\\n)*\"|'(?:[^'\\\\\\n]|\\\\.|\\\\\\n)*'|\\[=\\[[\\w\\W]*?\\]=\\]|\\[\\[[\\w\\W]*?\\]\\])";
final String string = "local a = getInterface() --- get \"interface\" (match here is ok, but not necessary)\n\n"
+ "[[ \n"
+ "multiline\n"
+ "string\n"
+ "\"\"\"\n"
+ "inside\n"
+ "\"\"\" (should not match the \"\"\" pattern\n"
+ "another\n"
+ "multiline]] (the outer multiline string should match)\n\n"
+ "local a = 0 -- silly'''comment (should not match the first ''' and look down for closing ''')\n\n"
+ "local a = ''' ---this is a normal multiline string and not a comment\n"
+ "''' (should match this)\n\n"
+ "\"\"\"filler'''filler\\\"\"\" (this should match \"\" and \"filler'''\\\"\" with a trailing \" unmatched\n\n"
+ "\"\"\"filler'''filler\\\"\"\"\" (This should match the entire line)";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}