re = /("""(?:[^"\\]|\\.|\\\n)*"""|\'\'\'(?:[^'\\]|\\.|\\\n)*\'\'\'|"(?:[^"\\\n]|\\.|\\\n)*"|'(?:[^'\\\n]|\\.|\\\n)*'|\[=\[[\w\W]*?\]=\]|\[\[[\w\W]*?\]\])/m
str = 'local a = getInterface() --- get "interface" (match here is ok, but not necessary)
[[
multiline
string
"""
inside
""" (should not match the """ pattern
another
multiline]] (the outer multiline string should match)
local a = 0 -- silly\'\'\'comment (should not match the first \'\'\' and look down for closing \'\'\')
local a = \'\'\' ---this is a normal multiline string and not a comment
\'\'\' (should match this)
"""filler\'\'\'filler\\""" (this should match "" and "filler\'\'\'\\"" with a trailing " unmatched
"""filler\'\'\'filler\\"""" (This should match the entire line)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end