import Foundation
let pattern = #"("""(?:[^"\\]|\\.|\\\n)*"""|\'\'\'(?:[^'\\]|\\.|\\\n)*\'\'\'|"(?:[^"\\\n]|\\.|\\\n)*"|'(?:[^'\\\n]|\\.|\\\n)*'|\[=\[[\w\W]*?\]=\]|\[\[[\w\W]*?\]\])"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
local a = getInterface() --- get "interface" (match here is ok, but not necessary)
[[
multiline
string
"""
inside
""" (should not match the """ pattern
another
multiline]] (the outer multiline string should match)
local a = 0 -- silly'''comment (should not match the first ''' and look down for closing ''')
local a = ''' ---this is a normal multiline string and not a comment
''' (should match this)
"""filler'''filler\""" (this should match "" and "filler'''\"" with a trailing " unmatched
"""filler'''filler\"""" (This should match the entire line)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)