# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(\"\"\"(?:[^\"\\]|\\.|\\\n)*\"\"\"|\'\'\'(?:[^'\\]|\\.|\\\n)*\'\'\'|\"(?:[^\"\\\n]|\\.|\\\n)*\"|'(?:[^'\\\n]|\\.|\\\n)*'|\[=\[[\w\W]*?\]=\]|\[\[[\w\W]*?\]\])"
test_str = ("local a = getInterface() --- get \"interface\" (match here is ok, but not necessary)\n\n"
"[[ \n"
"multiline\n"
"string\n"
"\"\"\"\n"
"inside\n"
"\"\"\" (should not match the \"\"\" pattern\n"
"another\n"
"multiline]] (the outer multiline string should match)\n\n"
"local a = 0 -- silly'''comment (should not match the first ''' and look down for closing ''')\n\n"
"local a = ''' ---this is a normal multiline string and not a comment\n"
"''' (should match this)\n\n"
"\"\"\"filler'''filler\\\"\"\" (this should match \"\" and \"filler'''\\\"\" with a trailing \" unmatched\n\n"
"\"\"\"filler'''filler\\\"\"\"\" (This should match the entire line)")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.