package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b[dlnmtsj]'|\w+(?:['-]\w+)*|[.,!?;]`)
var str = `Vincennes Confirmation des privilèges de la villed'Aire au bailliage d'Amiens Mai 1498 Aire-sur-la-Lys, Pas-de-Calais, arrondissement de Saint-Omer.
d'Amiens
d'Abrimcourt
villed'Aire`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}