$re = '/\b[dlnmtsj]\'|\w+(?:[\'-]\w+)*|[.,!?;]/m';
$str = 'Vincennes Confirmation des privilèges de la villed\'Aire au bailliage d\'Amiens Mai 1498 Aire-sur-la-Lys, Pas-de-Calais, arrondissement de Saint-Omer.
d\'Amiens
d\'Abrimcourt
villed\'Aire';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);