use strict;
my $str = 'Vincennes Confirmation des privilèges de la villed\'Aire au bailliage d\'Amiens Mai 1498 Aire-sur-la-Lys, Pas-de-Calais, arrondissement de Saint-Omer.
d\'Amiens
d\'Abrimcourt
villed\'Aire';
my $regex = qr/\b[dlnmtsj]'|\w+(?:['-]\w+)*|[.,!?;]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}