re = /\b[dlnmtsj]'|\w+(?:['-]\w+)*|[.,!?;]/m
str = 'Vincennes Confirmation des privilèges de la villed\'Aire au bailliage d\'Amiens Mai 1498 Aire-sur-la-Lys, Pas-de-Calais, arrondissement de Saint-Omer.
d\'Amiens
d\'Abrimcourt
villed\'Aire'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end