#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^[a-zA-Z0-9._-]+(\:[0-9]+)?[a-zA-Z0-9._/-]+$"
Local $sString = "registry.xxx.cn:60080/xx/envoyproxy/gateway" & @CRLF & _
"registry.xxx.cn:60080/xx/envoyproxy/gateway:xx" & @CRLF & _
"registry.xxx.cn/xx/envoyproxy/gateway:123" & @CRLF & _
"registry.xxx.cn:60080/xx/envoyproxy/gateway:123" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")