re = /^[a-zA-Z0-9._-]+(\:[0-9]+)?[a-zA-Z0-9._\/-]+$/m
str = 'registry.xxx.cn:60080/xx/envoyproxy/gateway
registry.xxx.cn:60080/xx/envoyproxy/gateway:xx
registry.xxx.cn/xx/envoyproxy/gateway:123
registry.xxx.cn:60080/xx/envoyproxy/gateway:123
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end