package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^[a-zA-Z0-9._-]+(\:[0-9]+)?[a-zA-Z0-9._/-]+$`)
var str = `registry.xxx.cn:60080/xx/envoyproxy/gateway
registry.xxx.cn:60080/xx/envoyproxy/gateway:xx
registry.xxx.cn/xx/envoyproxy/gateway:123
registry.xxx.cn:60080/xx/envoyproxy/gateway:123
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}