using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^[a-zA-Z0-9._-]+(\:[0-9]+)?[a-zA-Z0-9._/-]+$";
string input = @"registry.xxx.cn:60080/xx/envoyproxy/gateway
registry.xxx.cn:60080/xx/envoyproxy/gateway:xx
registry.xxx.cn/xx/envoyproxy/gateway:123
registry.xxx.cn:60080/xx/envoyproxy/gateway:123
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}