using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".*\blen\s+(\d+).*";
string input = @"111.112.111.0.0 > 111.33.44.55.11 pxs ikf len 3348
111.112.111.0.0 > 111.33.44.55.11 pxs ikf len 3348 BBBTTT";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}