const regex = /.*\blen\s+(\d+).*/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('.*\\blen\\s+(\\d+).*', 'g')
const str = `111.112.111.0.0 > 111.33.44.55.11 pxs ikf len 3348
111.112.111.0.0 > 111.33.44.55.11 pxs ikf len 3348 BBBTTT`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}