package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`.*\blen\s+(\d+).*`)
var str = `111.112.111.0.0 > 111.33.44.55.11 pxs ikf len 3348
111.112.111.0.0 > 111.33.44.55.11 pxs ikf len 3348 BBBTTT`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}