// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r".*\blen\s+(\d+).*").unwrap();
let string = "111.112.111.0.0 > 111.33.44.55.11 pxs ikf len 3348
111.112.111.0.0 > 111.33.44.55.11 pxs ikf len 3348 BBBTTT";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}