const regex = /\b\p{Ll}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b\\p{Ll}', 'gm')
const str = `customer.presentAddress.streetName`;
const subst = `\U\0`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);