$re = '/\b\p{Ll}/m';
$str = 'customer.presentAddress.streetName';
$subst = "\U\0";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;