re = /\b\p{Ll}/m
str = 'customer.presentAddress.streetName'
subst = '\\U\\0'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result