import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?P<feature_name>[\\w\\-]+)\\s+(?P<instance>\\d{1,3})\\s+(?P<state>\\w+)";
final String string = "switch# show feature \n"
+ "Feature Name Instance State\n"
+ "-------------------- -------- --------\n"
+ "assoc_mgr 1 enabled\n"
+ "cimserver 1 disabled\n"
+ "dhcp-snooping 1 disabled\n"
+ "fabric-binding 1 disabled\n"
+ "fc-port-security 1 disabled\n"
+ "fcoe 1 enabled\n"
+ "fcsp 1 disabled\n"
+ "fex 1 enabled\n"
+ "fport-channel-trunk 1 disabled\n"
+ "http-server 1 enabled\n"
+ "interface-vlan 1 enabled\n"
+ "lacp 1 enabled\n"
+ "ldap 1 disabled\n"
+ "lldp 1 enabled\n"
+ "niv 1 disabled\n"
+ "npiv 1 disabled\n"
+ "npv 1 disabled\n"
+ "otv 1 disabled\n"
+ "port_track 1 disabled\n"
+ "private-vlan 1 enabled\n"
+ "privilege 1 enabled\n"
+ "sshServer 1 enabled\n"
+ "tacacs 1 enabled\n"
+ "telnetServer 1 enabled\n"
+ "udld 1 enabled\n"
+ "vpc 1 enabled\n"
+ "vtp 1 enabled\n"
+ "switch#";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}