import Foundation
let pattern = #"(?P<feature_name>[\w\-]+)\s+(?P<instance>\d{1,3})\s+(?P<state>\w+)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
switch# show feature
Feature Name Instance State
-------------------- -------- --------
assoc_mgr 1 enabled
cimserver 1 disabled
dhcp-snooping 1 disabled
fabric-binding 1 disabled
fc-port-security 1 disabled
fcoe 1 enabled
fcsp 1 disabled
fex 1 enabled
fport-channel-trunk 1 disabled
http-server 1 enabled
interface-vlan 1 enabled
lacp 1 enabled
ldap 1 disabled
lldp 1 enabled
niv 1 disabled
npiv 1 disabled
npv 1 disabled
otv 1 disabled
port_track 1 disabled
private-vlan 1 enabled
privilege 1 enabled
sshServer 1 enabled
tacacs 1 enabled
telnetServer 1 enabled
udld 1 enabled
vpc 1 enabled
vtp 1 enabled
switch#
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)