# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?P<feature_name>[\w\-]+)\s+(?P<instance>\d{1,3})\s+(?P<state>\w+)"
test_str = ("switch# show feature \n"
"Feature Name Instance State\n"
"-------------------- -------- --------\n"
"assoc_mgr 1 enabled\n"
"cimserver 1 disabled\n"
"dhcp-snooping 1 disabled\n"
"fabric-binding 1 disabled\n"
"fc-port-security 1 disabled\n"
"fcoe 1 enabled\n"
"fcsp 1 disabled\n"
"fex 1 enabled\n"
"fport-channel-trunk 1 disabled\n"
"http-server 1 enabled\n"
"interface-vlan 1 enabled\n"
"lacp 1 enabled\n"
"ldap 1 disabled\n"
"lldp 1 enabled\n"
"niv 1 disabled\n"
"npiv 1 disabled\n"
"npv 1 disabled\n"
"otv 1 disabled\n"
"port_track 1 disabled\n"
"private-vlan 1 enabled\n"
"privilege 1 enabled\n"
"sshServer 1 enabled\n"
"tacacs 1 enabled\n"
"telnetServer 1 enabled\n"
"udld 1 enabled\n"
"vpc 1 enabled\n"
"vtp 1 enabled\n"
"switch#")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.