$re = '/(?P<feature_name>[\w\-]+)\s+(?P<instance>\d{1,3})\s+(?P<state>\w+)/m';
$str = 'switch# show feature
Feature Name Instance State
-------------------- -------- --------
assoc_mgr 1 enabled
cimserver 1 disabled
dhcp-snooping 1 disabled
fabric-binding 1 disabled
fc-port-security 1 disabled
fcoe 1 enabled
fcsp 1 disabled
fex 1 enabled
fport-channel-trunk 1 disabled
http-server 1 enabled
interface-vlan 1 enabled
lacp 1 enabled
ldap 1 disabled
lldp 1 enabled
niv 1 disabled
npiv 1 disabled
npv 1 disabled
otv 1 disabled
port_track 1 disabled
private-vlan 1 enabled
privilege 1 enabled
sshServer 1 enabled
tacacs 1 enabled
telnetServer 1 enabled
udld 1 enabled
vpc 1 enabled
vtp 1 enabled
switch#';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);