using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^#([0-9]+)\s+(.*?)$";
string input = @"#1 Connected
#2 Disconnected
#100 Playing CS:GO";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}