const regex = /^#([0-9]+)\s+(.*?)$/mg;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^#([0-9]+)\\s+(.*?)$', 'mg')
const str = `#1 Connected
#2 Disconnected
#100 Playing CS:GO`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}