re = /^#([0-9]+)\s+(.*?)$/m
str = '#1 Connected
#2 Disconnected
#100 Playing CS:GO'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end