$re = '/^#([0-9]+)\s+(.*?)$/m';
$str = '#1 Connected
#2 Disconnected
#100 Playing CS:GO';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);