# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(.+?)\1\b/\1/gm;t' <<< "John Smith
David BrownDavid Brown"