$re = '/\b(.+?)\1\b/m';
$str = 'John Smith
David BrownDavid Brown';
$subst = "\1";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;