import re
regex = re.compile(r"\b(.+?)\1\b", flags=re.MULTILINE)
test_str = ("John Smith\n"
"David BrownDavid Brown")
subst = "\\1"
result = regex.sub(subst, test_str)
if result:
print(result)