use strict;
my $str = 'John Smith
David BrownDavid Brown';
my $regex = qr/\b(.+?)\1\b/mp;
my $subst = '\\1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";