#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^\*\ headline\ \d+[\r\n]" & @CRLF & _
"(?:(?!\*).+[\r\n]?)+"
Local $sString = "* headline 0" & @CRLF & _
"* headline 1" & @CRLF & _
" :PROPERTIES:" & @CRLF & _
" :KEY: lala" & @CRLF & _
" :END:" & @CRLF & _
"* headline 2" & @CRLF & _
"* headline 3" & @CRLF & _
" :PROPERTIES:" & @CRLF & _
" :KEY: lblb" & @CRLF & _
" :END:"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")