$re = '/^\*\ headline\ \d+[\r\n]
(?:(?!\*).+[\r\n]?)+/mx';
$str = '* headline 0
* headline 1
:PROPERTIES:
:KEY: lala
:END:
* headline 2
* headline 3
:PROPERTIES:
:KEY: lblb
:END:';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);