package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\*\ headline\ \d+[\r\n]
(?:(?!\*).+[\r\n]?)+`)
var str = `* headline 0
* headline 1
:PROPERTIES:
:KEY: lala
:END:
* headline 2
* headline 3
:PROPERTIES:
:KEY: lblb
:END:`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}