re = /^\*\ headline\ \d+[\r\n]
(?:(?!\*).+[\r\n]?)+/mx
str = '* headline 0
* headline 1
:PROPERTIES:
:KEY: lala
:END:
* headline 2
* headline 3
:PROPERTIES:
:KEY: lblb
:END:'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end