package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)Name: (?<name>[^\n]+)[\n\r]+Email: (?<email>[^\n]+)[\n\r]+Phone: (?<phone>[^\n]+)[\n\r]+Business: (?<business>[^\n]+)[\n\r]+Message: (?<message>[^\n]+)`)
var str = `Name: John Smith
Email: sitelab@gmail.com
Phone: 0952145879
Business: Marketing agency
Message: I’m interested in your services`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}