# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"Name: (?<name>[^\n]+)[\n\r]+Email: (?<email>[^\n]+)[\n\r]+Phone: (?<phone>[^\n]+)[\n\r]+Business: (?<business>[^\n]+)[\n\r]+Message: (?<message>[^\n]+)"
test_str = ("Name: John Smith\n"
"Email: sitelab@gmail.com\n"
"Phone: 0952145879\n"
"Business: Marketing agency\n"
"Message: I’m interested in your services")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.