re = /Name: (?<name>[^\n]+)[\n\r]+Email: (?<email>[^\n]+)[\n\r]+Phone: (?<phone>[^\n]+)[\n\r]+Business: (?<business>[^\n]+)[\n\r]+Message: (?<message>[^\n]+)/m
str = 'Name: John Smith
Email: sitelab@gmail.com
Phone: 0952145879
Business: Marketing agency
Message: I’m interested in your services'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end